Zwei Spalten in Google Docs vergleichen

Nehmen wir an, wir haben zwei Spalten A und B mit jeweils Wörtern (Strings) drin. Nun will ich wissen, ob ein Wort in Spalte A auch in Spalte B vorhanden ist. Wenn man nun tausende Wörter miteinander vergleicht, dann kann der naive manuelle Ansatz einfach der Falsche sein. GoogleDocs bzw. Excel kennen die Funktion ARRAYFORMULA. Damit kann man sich in Spalte C zum Beispiel ein ‚X‘ anzeigen lassen, wenn das Wort in Spalte B gefunden wurde.

In das Feld C1 kopiert man nun einfach diese Formel:

=ARRAYFORMULA(IF(ISTEXT(A2:A); REPT( "X " ;MMULT((A2:A =TRANSPOSE(B2:B)); SIGN(ROW(A2:A)))); IFERROR(1/0)))

Das sieht dann im Endergebnis so aus wie auf dem Screenshot. In Spalte C wird mit jedem X visualisiert, wie oft der Begriff vorkommt. Das X kann man in der Formel auch bequem gegen etwas anderes austauschen oder die Formel so erweitern, dass die Anzahl der Vorkommnisse angezeigt wird. Eine Lösung in den Kommentaren ist immer gern gesehen.

Spalten vergleichen in GoogleDocs

3 Antworten auf „Zwei Spalten in Google Docs vergleichen“

  1. Vielleicht sehe ich gerade die notwendige Komplexität nicht, aber zumindest in Excel mach ich das so:

    =WENN(ISTFEHLER(SVERWEIS(A1;$B:$B;1;FALSCH));"";"x")

    Einen einfachen SVerweis eines Wertes aus A auf die gesamte Spalte B. Wird der Wert nicht gefunden, wird ein Fehler geworfen. Tritt der Fehler auf, ist der Wert also nicht vorhanden, tritt kein Fehler auf, ist der Wert demzufolge vorhanden. Fertig ist die Laube.

    Die Anzahl der Vorkommen werden nicht gezählt, klar, und es ist auch nicht so „schick“, aber schnell und simpel.




    0

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website zeigt Benutzerbilder über gravatar.com an.